evitar el clonado de mac

flavio

New Member
Como hacerle para bloquear el clonado mac desde software
winbox y evitar que un usuario burle el amarrado de ip con
mac para controlar el ancho de banda. Si alguien me puede
ayudar se lo agradeceré infinitamente.

Gracias.
 
Última edición por un moderador:

flavio

New Member
Gracias ing por darse el tiempo en contestar, sin embargo mi duda va enfocada
a que yo amarro una ip con su mac de un determinado usuario con winbox y el
usuario al poco rato ya clono su mac y le asigna una nueva ip, es decir, mac e ip
nueva; el winbox lo detecta como un usuario nuevo y tiene conexión de nuevo
sin restricción alguna y así no puedo controlarlo. Existe alguna alternativa en
winbox para bloquear macs duplicadas.

Alguien que le haya pasado esto y le dio solución se lo agradecería mucho y pudiera
compartir su experiencia.

Gracias.
 
Última edición por un moderador:

Renato Espoz L.

Moderator
Miembro del equipo
Hola Flavio.

Lamentablemente es dificil hacer lo que pides.

Solo he visto una vez algo asi y era mas complejo de lo que se escribe.
El sistema de Seguridad (de una empresa lider en NETWORKING) no solo amarra la MAC a una ip, si no que tambien nombre del dispositivo. De esta forma es muy dificil lograr que se conecte. Pero actualmente ya existen dispositivos que permiten clonar MAC, nombre e IP.

Lo que yo te recomendaria es que crees una address list que cuando detecte una cambio en la MAC y /o IP, lo bloquee inmediatamente, asi el "cliente" finalmente no se cambiara más ya que cada cambio lo botara de la red.
En Resumen, lo aburres por cansancio.


Nos vemos
 
Hola, como estan?.
Segun el curso de Rodrigo se puede hacer, al menos en teoria, con equipos mikrotik.
El procedimiento seria IP/ARP, en la ip y mac que aparecen conectados se selecciona y luego MAKE STATIC, se puede colocar comentario de quien es,
Luego en la interface, en mi caso LAN/ARP colocar "reply-only, y se supone que asi seria. Tambien se puede agregar a una lista negra las ip que no estan en el rango de clientes.
Espero que le sirva.
 

Renato Espoz L.

Moderator
Miembro del equipo
Tambien es posible crear un script que guarde el nombre del dispositivo y la MAC y asi compararlas con cada conexion nueva. Si esta cambia, se va al adresslist
 

Renato Espoz L.

Moderator
Miembro del equipo
Hola Mano...

No te mentire, no lo he hecho nunca porque no se me ha planteado la situacion.
Tendrias que darme unso dias porque estoy copado de trabajo y desarrollar algo.

PEro seguro alguno de los chicos aca puede hacerlo mas rapido. Si no esta cuando tenga tiempo, lo desarrollare y lo posteo. (Pero de plano te digo que necesitara un lugar donde guardar las tablas con los datos) XD

Saludos
 

DGOlivera

New Member
amigos como se puede evitar que te clonen la mac de tu equipos tengo dos mikrotik y me los tienen clonados y me tumban la coneccion desde la noche hasta el otro dia en la mañana hay algun scritp que te cambia la mac cada cierto tiempo saludos
 

NOX

Member
Si tienes un cliente que te esta molestando ... por que no lo retiras del servicio? El amarre de ip/mac solo usa esa informacion, si se cambia la mac y el ip por otro no tienes como controlarlo ... yo tuve un problema similar hace poco donde el ip de mi gateway lo tenia puesto otra persona y cuando se conectava me interrumpia el servicio porque el trafico de los clientes se desviaba hacia esa persona, lo detecte y solucione porque tengo un switch gestionable, me detecto una colision de ip al estar repetidos con la mac bloquee el acceso de esa ip por el puerto al que estaba y ya no tenia mas acceso a la red. En el caso mencionado si la persona que esta clonando entra por lan ... localizalo y desconectalo!!! si entra por wifi activa el ACL y ponle contraseña ... te podra clonar ip/mac ... pero la contraseña no ...
 

NOX

Member
amigos como se puede evitar que te clonen la mac de tu equipos tengo dos mikrotik y me los tienen clonados y me tumban la coneccion desde la noche hasta el otro dia en la mañana hay algun scritp que te cambia la mac cada cierto tiempo saludos
si ... usa este:

:local r
:local tonum do={
:local in ($1->0)
:local j
:for i from=0 to=([:len $in]-1) do={
:local t
:set t [:pick $in $i]
:if ($t!=" ") do={:set $j "$j$t"}
}
:set j ([:tonum $j])
:return $j
}

:local hex 0123456789abcdef
:local mac "";

:set r [/interface ethernet get ether1 rx-bytes]
:set r [$tonum $r]
:local i1 ($r/16)
:set i1 ($i1-($i1/16)*16)
:local i2 ($r-($r/16)*16)
:set r [/interface ethernet get ether1 rx-64]
:set r [$tonum $r]
:local i3 ($r/16)
:set i3 ($i3-($i3/16)*16)
:local i4 ($r-($r/16)*16)
:set r [/interface ethernet get ether1 rx-65-127]
:set r [$tonum $r]
:local i5 ($r/16)
:set i5 ($i5-($i5/16)*16)
:local i6 ($r-($r/16)*16)
:set r [/interface ethernet get ether1 tx-bytes]
:set r [$tonum $r]
:local i7 ($r/16)
:set i7 ($i7-($i7/16)*16)
:local i8 ($r-($r/16)*16)
:set r [/interface ethernet get ether1 tx-64]
:set r [$tonum $r]
:local i9 ($r/16)
:set i9 ($i9-($i9/16)*16)
:local i10 ($r-($r/16)*16)
:set r [/interface ethernet get ether1 tx-65-127]
:set r [$tonum $r]
:local i11 ($r/16)
:set i11 ($i11-($i11/16)*16)
:local i12 ($r-($r/16)*16)

:set mac ([:tostr [:pick $hex $i1]].[:tostr [:pick $hex $i2]].[:tostr [:pick $hex $i3]].[:tostr [:pick $hex $i4]].[:tostr [:pick $hex $i5]].[:tostr [:pick $hex $i6]].[:tostr [:pick $hex $i7]].[:tostr [:pick $hex $i8]].[:tostr [:pick $hex $i9]].[:tostr [:pick $hex $i10]].[:tostr [:pick $hex $i11]].[:tostr [:pick $hex $i12]]);
:log warning "New MAC $mac"
/interface wireless set NOMBRE_DE_TU_INTERFACE mac-address=$mac;

Este script te genera una mac aleatoria cada ves que lo ejecutes tomando parametros de tu mikrotik ... puedes programarlo cada 10 minutos
 
Arriba